Jump to content

Weird framerate on old Sonic games under Windows 10


Recommended Posts

Hey guys! I've been having this problem since I updated to Windows 10. As long as I remember this didn't happen on 7.
Randomly during gameplay, the games start to stutter heavily, as if they're running around 20/25 fps, when they usually run at fixed 60. The framerate counter does not show any drop, and so does the frametime counter (it has spikes to 20ms at times but it happens on other games too and it's not that bad. I tried v-sync, setting the FPS cap with Rivatuner, Nvidia Inspector and nothing made a difference.
The games in question are Sonic Heroes and Sonic Adventure DX (2004 version).
I wonder if this has to do with the OS, or drivers.
I have tried setting compatibility mode, disabling antialiasing and effects, really anything. Is anyone experiencing the same?


i5 6600 3.4ghz
GTX 970
8gb DDR4

Link to comment
Share on other sites

Oh, yeah, I'm having similar issues with those games as well. Sadly, I don't know a solution to it yet, but maybe if you try playing them on a Virtual Machine, it might work? If not, you might have to go back to Windows 7 again.

  • Thumbs Up 1
Link to comment
Share on other sites

I tried the Virtual Machine thing, but the framerate was even worse, so that's not an option. Going back to 7 isn't one either because of DX 12. Glad to hear I'm not the only one tho, it means I'm not seeing things!

  • Thumbs Up 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...

Important Information

You must read and accept our Terms of Use and Privacy Policy to continue using this website. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.